Author Topic: Lagging out in Mudlet  (Read 229 times)

tortall

  • Posts: 2263
Lagging out in Mudlet
« on: May 01, 2020, 10:25:26 AM »
Ok hive mind. I keep having problems lagging out. Sometimes it's just lag, but sometimes I'll enter a command and it will appear to not go through and I just sit there and it won't do anything until I reconnect. Apparently what I SENT is going through, but I'm lagged out. I just changed from MUSHClient to Mudlit, and at first it was doing good, but.... Got REALLY bad last night. To the point I basically couldn't play. :-( Suggestions? I know we had a ton of folks on last night, but we've had more than that before without problems. The folks I was RPing with didn't seem to be having any issue.

I seem to be connected to everything else online just fine. It's just Arm that's the issue. This is sadly why I took a break last time. When I play from my phone, no issues, but.... Yah, not ideal.
The man asks you:
     "'Bout damn time, lol.  She didn't bang you up too bad, did she?"
The man says, ooc:
     "OG did i jsut do that?"

Quote from: Shalooonsh
I love the players of this game.
That's not a random thought either.

Alesan

  • Posts: 368
Re: Lagging out in Mudlet
« Reply #1 on: May 01, 2020, 01:32:07 PM »
This sounds more like a general connectivity issue than a Mudlet issue, but I take it you don't have this problem on any client but Mudlet? Have you gone back to Mushclient, or used the web client, to test? If it is unique to Mudlet, have you played with any of the connection settings to see if one of them is the issue?

triste

  • Posts: 180
Re: Lagging out in Mudlet
« Reply #2 on: May 01, 2020, 04:04:48 PM »
I'll enter a command and it will appear to not go through

This happens to me as well, and I saw another player mention this happening to them specifically in Mudlet. There are apparently some settings you can tweak with in Mudlet to fix this, but usually resending the command should work in this case.

If resending doesn't work, and the connection just hangs, this possibly has to do with your actual connection / IP address changing. If you have multiple wifi networks for example, and your computer will switch between them, the connection "hangs until you reconnect" because muds are crude and can only handle one persistent connection from a given address [unlike most modern software that can handle automatically reconnecting from a new address which may explain why you don't see the issue elsewhere].

Just two causes of this that I have seen, someone else might have better answers.
will do my best to maintain https://tristearmageddon.github.io/arma-guild-picker/, message me if something there needs an update.

Decameron

  • Posts: 589
Re: Lagging out in Mudlet
« Reply #3 on: May 02, 2020, 01:07:36 PM »
This has been happening to me a lot, but in CMUD. Connection flat out drops despite what I am doing. I am not noticing a connection issue anywhere else (i.e. working while working from home)

Been trying to debug the issue today, as it is slowly getting to the point of not being able to play.

tortall

  • Posts: 2263
Re: Lagging out in Mudlet
« Reply #4 on: May 03, 2020, 10:09:04 PM »
This has been happening to me a lot, but in CMUD. Connection flat out drops despite what I am doing. I am not noticing a connection issue anywhere else (i.e. working while working from home)

Been trying to debug the issue today, as it is slowly getting to the point of not being able to play.

That's three clients. I do just fine on Blowtorch on my phone, but that's rough to do more than busy work.
The man asks you:
     "'Bout damn time, lol.  She didn't bang you up too bad, did she?"
The man says, ooc:
     "OG did i jsut do that?"

Quote from: Shalooonsh
I love the players of this game.
That's not a random thought either.